WP Wolf Support Forum
by BrutalDesign
We will close this forum soon. Sign up to the new forum now!
Regarding the number of my available themes and the amount of support requests I have to handle every day, I decided that my support services will only cover theme setup, trouble using any features, and bug fixes. Regretfully I can't provide support for modifications or 3rd party plugins issues. Thanks for your understanding.
Warning: Creating default object.. on top of Music Pro Theme.
  • Hello,

    I have the following message on top of all my pages for Music Pro.

    "Warning: Creating default object from empty value in \\WDP\DFS\30\7\6\1\3081342167\user\sites\3235434.site\www\wordpress1\wp-content\themes\musicpro\framework\theme\bd-functions.php on line 80"

    How do I make it go away?
  • Hi,

    In framework\theme\bd-functions.php replace the row 32 to 36 by the following:
    function bd_meta_head() { do_action('bd_meta_head'); }
    function bd_head() { do_action('bd_head'); }
    function bd_footer() { do_action('bd_footer'); }
    function bd_body_start() { do_action('bd_body_start'); }
    function bd_body_end() { do_action('bd_body_end'); }
    function bd_post_end() { do_action('bd_post_end'); }


    Pls let me know if it fixes the issue.
  • That seems to have made it a little worse. The theme will not load now.

    Content Encoding Error
    The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    Is the error. I tried going to a backup copy of the file with the orginal entries. It did not work. I would welcome any suggestions.
  • I have been able to restore the page but that code takes the entire theme out.
  • Hi,

    please give me your URL, Wordpress login and FTP infos.
    I will try to fix this.

    Regards
  • Add the following above the comment, musicpro\framework\theme\bd-functions.php at row 204:

    if (!is_object($query_context)) {
    $query_context = new stdClass;
    }

    /* Figure out the context ------------------------------------------------*/
  • Hey,

    i wrote you via THEMEFOREST because of this problem.
    Now I have just replaced the rows 32 to 36 as you mentioned above.
    Et voilà, all works fine!

    In my case it seemed to be a problem with the new PHP-Version 5.4.

    Thanks again, Heiner

This forum is for verified costumers only.

Sign In or Create an account

Tagged